设计一个名为Rectangle的类来表示一个矩形。 该类包含: 名为width和length的两个int数据字段,用于指定矩形的宽度和长度; 一个无参数构造函数,用于创建宽度为0且长度为0的默认矩形; 一个构造函数,它创建一个带有两个参数的矩形:width1和length1; 一个名为getRectangle()的函数,它将宽度和长度分配给矩形; 一个名为getArea()的函数返回该区域; 一个名为getPerimeter()的函数,用于返回周长。 编写一个创建Rectangle对象的测试程序。 为对象指定宽度和长度。 显示区域和周长。 【输入形式】两个整数 【输出形式】两个整数(面积和周长) 【样例输入】3 4 【样例输出】 The Area is 12 The Perimeter is 14用c++写代码
时间: 2024-02-06 20:11:22 浏览: 201
```c++
#include<iostream>
using namespace std;
class Rectangle {
private:
int width;
int length;
public:
Rectangle() {
width = 0;
length = 0;
}
Rectangle(int width1, int length1) {
width = width1;
length = length1;
}
void getRectangle(int width1, int length1) {
width = width1;
length = length1;
}
int getArea() {
return width * length;
}
int getPerimeter() {
return 2 * (width + length);
}
};
int main() {
int width, length;
cin >> width >> length;
Rectangle rect(width, length);
cout << "The Area is " << rect.getArea() << endl;
cout << "The Perimeter is " << rect.getPerimeter() << endl;
return 0;
}
```
阅读全文