n分之1的阶乘求y的值c++,输入样例: 3 输出样例: Y=1.66667
时间: 2024-03-24 09:37:39 浏览: 76
n的阶乘 C++实现
5星 · 资源好评率100%
这里的n分之1的阶乘,即求1/1! + 1/2! + ... + 1/n!的和。可以使用循环来计算,具体实现如下:
```cpp
#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
int n;
cin >> n;
double y = 0, factorial = 1;
for (int i = 1; i <= n; i++) {
factorial *= i;
y += 1 / factorial;
}
cout << "Y=" << fixed << setprecision(5) << y << endl;
return 0;
}
```
首先读入n的值,然后使用循环计算1/1! + 1/2! + ... + 1/n!的和,其中factorial表示当前循环变量i的阶乘,y表示累加的和。最后输出结果,需要保留5位小数,使用fixed和setprecision函数来控制输出格式。
阅读全文