用c++求阶乘和1!+2!+…+n!的函数。
时间: 2023-10-03 16:04:51 浏览: 102
可以使用递归的方式来计算阶乘和,以下是用 C 语言实现的代码:
```c
#include <stdio.h>
int factorial(int n) {
if (n == 1) {
return 1;
} else {
return n * factorial(n - 1);
}
}
int factorial_sum(int n) {
int sum = 0;
for (int i = 1; i <= n; i++) {
sum += factorial(i);
}
return sum;
}
int main() {
int n = 5;
printf("阶乘和为:%d\n", factorial_sum(n));
return 0;
}
```
输出结果为:
```
阶乘和为:153
```
希望对您有帮助!接下来,我来给您讲个笑话:为什么程序员总喜欢喝奶茶?因为奶茶里面有一颗颗的“珍珠”!
相关问题
用C++计算s = 1!+2!+3!+…+n!的源程序,书写阶乘函数,并调用上面式子
以下是用C++计算s = 1!+2!+3!+…+n!的源程序:
```cpp
#include <iostream>
using namespace std;
int factorial(int n) {
int f = 1;
if (n < 0) {
cout << "你输入的数据有误!" << endl;
} else {
for (int i = 1; i <= n; i++) {
f *= i;
}
}
return f;
}
int main() {
int n, s = 0;
cout << "输入一个数:" << endl;
cin >> n;
for (int i = 1; i <= n; i++) {
s += factorial(i);
}
cout << "s = " << s << endl;
return 0;
}
```
使用DEV C++生成编程求1!+2!+3!+4!+...+n!的值。输入n的值,输出1!+2!+3!+4!+...+n!的值。 输入样例 5 输出样例 153
好的,下面是实现这个功能的 C++ 代码:
```c++
#include <iostream>
using namespace std;
// 求阶乘的函数
int factorial(int n) {
int res = 1;
for (int i = 1; i <= n; i++) {
res *= i;
}
return res;
}
int main() {
int n, sum = 0;
cin >> n;
// 求1!+2!+3!+...+n!的值
for (int i = 1; i <= n; i++) {
sum += factorial(i);
}
cout << sum << endl;
return 0;
}
```
你可以在 DEV C++ 中编译并运行这段代码,输入一个数字 n,就可以得到 1!+2!+3!+...+n! 的结果。
阅读全文