用java写 描述 根据参数,画出矩形。 输入 输入一行,包括四个参数:前两个参数为整数,依次代表矩形的高和宽(高不少于3行不多于10行,宽不少于5列不多于10列);第三个参数是一个字符,表示用来画图的矩形符号;第四个参数为1或0,0代表空心,1代表实心。 输出 输出画出的图形。 样例输入 7 7 @ 0 样例输出 @@@@@@@ @ @ @ @ @ @ @ @ @ @ @@@@@@@
时间: 2023-09-30 20:04:49 浏览: 199
JUXING.zip_AppRetCode_参数化
以下是用 Java 实现的代码,可以实现根据参数画出矩形:
```java
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int height = sc.nextInt(); // 矩形高度
int width = sc.nextInt(); // 矩形宽度
char symbol = sc.next().charAt(0); // 矩形符号
int isSolid = sc.nextInt(); // 是否实心
if (height < 3 || height > 10 || width < 5 || width > 10) {
System.out.println("输入参数不符合要求!");
return;
}
if (isSolid == 1) { // 实心矩形
for (int i = 0; i < height; i++) {
for (int j = 0; j < width; j++) {
System.out.print(symbol);
}
System.out.println();
}
} else { // 空心矩形
for (int i = 0; i < height; i++) {
for (int j = 0; j < width; j++) {
if (i == 0 || i == height - 1 || j == 0 || j == width - 1) {
System.out.print(symbol);
} else {
System.out.print(" ");
}
}
System.out.println();
}
}
}
}
```
输入格式为:
```
7 7 @ 0
```
输出结果为:
```
@@@@@@@
@ @
@ @
@ @
@ @
@ @
@@@@@@@
```
阅读全文