#include <iostream> #include <cstring> #include <string> using namespace std; class String { private: char *p; public: // 你的代码在这里 } int main() { String s1, s2; s1.input(); s2.input(); s1.display(); s2.display(); cout << (s1 > s2) << endl; cout << (s1 < s2) << endl; cout << (s1 == s2) << endl; return 0; } 输入 两个不带空格的字符串 输出 按样例要求输出 样例输入 Copy Hello Book 样例输出 Copy Hello Book 1 0 0
时间: 2024-03-15 11:46:43 浏览: 127
使用include <iostream>时一定要加using namespace std
下面是实现 String 类的代码:
```c++
#include <iostream>
#include <cstring>
#include <string>
using namespace std;
class String {
private:
char *p;
public:
String() { // 构造函数
p = NULL;
}
~String() { // 析构函数
if (p) {
delete[] p;
}
}
void input() { // 输入字符串
string str;
cin >> str;
p = new char[str.length() + 1];
strcpy(p, str.c_str());
}
void display() { // 输出字符串
cout << p << endl;
}
bool operator>(const String &s) { // 大于运算符
return strcmp(p, s.p) > 0;
}
bool operator<(const String &s) { // 小于运算符
return strcmp(p, s.p) < 0;
}
bool operator==(const String &s) { // 等于运算符
return strcmp(p, s.p) == 0;
}
};
int main() {
String s1, s2;
s1.input();
s2.input();
s1.display();
s2.display();
cout << (s1 > s2) << endl;
cout << (s1 < s2) << endl;
cout << (s1 == s2) << endl;
return 0;
}
```
该程序中,String 类有一个指针成员变量 `p`,它指向一个字符串。构造函数将 `p` 初始化为 `NULL`,析构函数释放 `p` 指向的内存。`input()` 函数从标准输入读入一个字符串,将其存放到 `p` 指向的内存中。`display()` 函数将 `p` 指向的字符串输出到标准输出中。`operator>`, `operator<`, `operator==` 分别重载了大于、小于和等于运算符,它们使用 `strcmp` 函数比较两个字符串的大小关系。在 `main()` 函数中,先创建两个 String 类对象 s1 和 s2,分别调用它们的 `input()` 函数输入字符串,再依次调用它们的 `display()` 函数输出字符串,最后调用它们的比较运算符函数输出比较结果。
阅读全文