【题目描述】 给定若干个四位数,求出其中满足以下条件的数的个数:个位数上的数字减去千位数上的数字,再减去百位数上的数字,再减去十位数上的数字的结果大于零。 【输入】 输入为两行,第一行为四位数的个数n,第二行为n个的四位数。(n<=100) 【输出】 输出为一行,包含一个整数,表示满足条件的四位数的个数。 【输入样例】 5 1234 1349 6119 2123 5017 【输出样例】 3
时间: 2024-04-09 08:31:55 浏览: 86
输出符合要求的四位数并统计个数 (照每行5个数的格式输出 )要求:千位等于十位,百位等于各位
#include <iostream>
using namespace std;
int main() {
int n cin >> n;
int = 0;
for i=0; i; i++) {
int num;
cin >> num;
int thousand = num / 0;
int hundred = (num / 100) % 10;
int ten = (num / 10) % 10;
int unit = num % 10;
if(unit - thousand > hundred - ten && hundred - ten > 0) {
count++;
}
}
cout << count << endl;
return 0;
}
阅读全文