设计Point点类,成员数据包含坐标x和y,都是int类型。根据给定的main设计必要的成员函数。 main函数已给定,提交时只需要提交main函数外的代码部分。 #include<iostream> using namespace std; //你提交的代码在这里 int main() { Point p1,p2(20,100); cout<<"Show object p1:"; p1.Show(); cout<<"Show object p2:"; p2.Show(); int x,y; cin>>x>>y; cout<<"Reset and Show object p1:"; p1.Set(x,y); p1.Show(); cin>>x>>y; cout<<"Reset and Show object p2:"; p2.Set(x,y); p2.Show(); return 0; } 输入 2行,每行2个整数,分别表示二维坐标系中一个的x坐标和y坐标。数据保证在int范围内。 输出 输出包含4行,按照样例输出格式输出。 输入样例 1 -10 -10 0 0 输出样例 1 Show object p1:(10,16) Show object p2:(20,100) Reset and Show object p1:(-10,-10) Reset and Show object p2:(0,0)
时间: 2024-03-23 09:40:33 浏览: 53
11-19-PointClass:创建一个名为 Point 的类,该类将二维空间中某个位置的 (x, y) 坐标存储为整数
```cpp
#include<iostream>
using namespace std;
class Point{
private:
int x, y;
public:
Point(){
x = 10;
y = 16;
}
Point(int a, int b){
x = a;
y = b;
}
void Set(int a, int b){
x = a;
y = b;
}
void Show(){
cout << "(" << x << "," << y << ")" << endl;
}
};
int main() {
Point p1,p2(20,100);
cout<<"Show object p1:";
p1.Show();
cout<<"Show object p2:";
p2.Show();
int x,y;
cin>>x>>y;
cout<<"Reset and Show object p1:";
p1.Set(x,y);
p1.Show();
cin>>x>>y;
cout<<"Reset and Show object p2:";
p2.Set(x,y);
p2.Show();
return 0;
}
```
阅读全文