1035:等差数列末项计算 时间限制: 1000 ms 内存限制: 65536 KB 提交数: 65333 通过数: 49256 【题目描述】 给出一个等差数列的前两项a1,a2a1,a2,求第nn项是多少。 【输入】 一行,包含三个整数a1,a2,na1,a2,n。−100≤a1,a2≤100,0<n≤1000−100≤a1,a2≤100,0<n≤1000。 【输出】 一个整数,即第nn项的值。 【输入样例】 1 4 100 【输出样例】 298
时间: 2024-03-23 15:38:11 浏览: 89
根据等差数列的通项公式 $a_n = a_1+(n-1)d$,其中 $d$ 为公差,可以求出公差 $d=a_2-a_1$,然后代入公式求出 $a_n$ 即可。
Python 代码如下:
```python
a1, a2, n = map(int, input().split())
d = a2 - a1
an = a1 + (n - 1) * d
print(an)
```
相关问题
Java 7:等差数列末项计算 【题目描述】 给出一个等差数列的前两项a1,a2,求第n项是多少。 【输入】 一行,包含三个整数a1,a2,n
好的,以下是Java实现的示例代码:
```java
import java.util.Scanner;
public class APSequence {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
System.out.print("请输入等差数列的前两项和要求的第几项(空格分隔):");
int a1 = input.nextInt(); // 第一项
int a2 = input.nextInt(); // 第二项
int n = input.nextInt(); // 第n项
int d = a2 - a1; // 公差
int an = a1 + (n - 1) * d; // 第n项
System.out.println("第" + n + "项是:" + an);
}
}
```
你可以在控制台输入等差数列的前两项和要求的第几项,程序将会输出第n项的值。例如,如果输入2 4 6,则输出第6项是10。
等差数列末项计算c++
在C++中,可以使用以下代码来计算等差数列的末项:
```cpp
#include <iostream>
using namespace std;
int main() {
int firstTerm, commonDifference, n;
cout << "Enter the first term: ";
cin >> firstTerm;
cout << "Enter the common difference: ";
cin >> commonDifference;
cout << "Enter the number of terms: ";
cin >> n;
int lastTerm = firstTerm + (n - 1) * commonDifference;
cout << "The last term of the arithmetic progression is: " << lastTerm << endl;
return 0;
}
```
在这段代码中,我们首先输入等差数列的首项、公差和项数。然后,使用公式 `lastTerm = firstTerm + (n - 1) * commonDifference` 计算出末项的值,并将其输出。
请注意,此代码假设输入的数值均为整数。如果你需要处理浮点数,请将变量的类型更改为`float`或`double`。
阅读全文