图的广度优先搜索 描述: 图的广度优先搜索类似于树的按层次遍历,即从某个结点开始,先访问该结点,然后访问该结点的所有邻接点,再依次访问各邻接点的邻接点。如此进行下去,直到所有的结点都访问为止。在该题中,假定所有的结点以“A”--“Z”中的若干字符表示,且要求结点的访问顺序要求根据由“A”至“Z”的字典顺序进行访问。例如有如下图: 如果要求从H开始进行广度优先搜索,则搜索结果为:H->A->E->K->U. 输入: 输入只包含一个测试用例,第一行为一个自然数n,表示顶点的个数,第二行为n个大写字母构成的字符串,表示顶点,接下来是为一个n*n大小的矩阵,表示图的邻接关系。数字为0表示不邻接,否则为相应的边的长度。 最后一行为一个字符,表示要求进行广度优先搜索的起始顶点。 输出: 用一行输出广度优先搜索结果,起始点为给定的顶点,各顶点之间用一个空格隔开。要求同一顶点的邻接点的访问顺序按“A”---“Z”的字典顺序。 样例输入: 5 HUEAK 0 0 2 3 0 0 0 0 7 4 2 0 0 0 0 3 7 0 0 1 0 4 0 1 0 H 样例输出: H A E K U,用c++来写
时间: 2024-03-16 14:47:33 浏览: 37
图的广度优先搜索遍历
以下是广度优先搜索的 C++ 实现代码:
```cpp
#include <iostream>
#include <vector>
#include <queue>
#include <map>
using namespace std;
int main() {
int n;
cin >> n;
vector<char> nodes(n);
for (int i = 0; i < n; i++) {
cin >> nodes[i];
}
vector<vector<int>> graph(n, vector<int>(n));
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
cin >> graph[i][j];
}
}
char start_node;
cin >> start_node;
// 将节点映射到数字
map<char, int> node_to_num;
for (int i = 0; i < n; i++) {
node_to_num[nodes[i]] = i;
}
// 从起始节点开始进行广度优先搜索
vector<bool> visited(n, false);
queue<int> q;
q.push(node_to_num[start_node]);
visited[node_to_num[start_node]] = true;
vector<char> result;
while (!q.empty()) {
int curr_node = q.front();
q.pop();
result.push_back(nodes[curr_node]);
// 遍历所有邻接节点,并按字典序排序
vector<int> neighbors;
for (int i = 0; i < n; i++) {
if (graph[curr_node][i] != 0 && !visited[i]) {
neighbors.push_back(i);
}
}
sort(neighbors.begin(), neighbors.end(), [&](int a, int b) { return nodes[a] < nodes[b]; });
for (int neighbor : neighbors) {
q.push(neighbor);
visited[neighbor] = true;
}
}
// 输出结果
for (char node : result) {
cout << node << " ";
}
cout << endl;
return 0;
}
```
输入格式和输出格式见题目描述。
阅读全文