本题目要求读入2个实数a和b,生成一个复数a+jb,能够计算这个复数的模并输出。复数类的定义和主函数如下: class Complex{ private: double real; double image; public: Complex(double r,double i); void display(); double abscomplex(); }; int main() { double a,b; cin>>a>>b; Complex A(a,b); A.display(); cout<<A.abscomplex()<<endl; return 0; } 输入格式: 输入在一行中给出2个绝对值不超过100的两个实数,两者之间用空格分隔开。 输出格式: 对每一组输入,在一行中输出复数及其摸。复数模等于实部的平方与虚部的平方之和,再开方。 输入样例: 在这里给出三组输入。例如: 3 -4 0 0 100 100 输出样例: 在这里给出相应的输出(注意:冒号之后空一格)。例: 3-4i: 5 0: 0 100+100i: 141.421
时间: 2023-05-26 12:07:00 浏览: 165
计算两个5*5矩阵的乘积
#include <iostream>
#include <cmath>
#include <iomanip> // 输出保留小数点用到的头文件
using namespace std;
class Complex {
private:
double real;
double image;
public:
Complex(double r, double i) {
real = r;
image = i;
}
void display() {
cout << setprecision(1) << fixed << real << (image >= 0 ? "+" : "") << image << "i"; // 将输出保留1位小数
}
double abscomplex() {
return sqrt(real * real + image * image);
}
};
int main() {
double a, b;
cin >> a >> b;
Complex A(a, b);
A.display();
cout << ": " << A.abscomplex() << endl;
return 0;
}
阅读全文