用java设计一个Point类,表示直角坐标系中的一个点。Point类包括: (1)double类型的私有变量x和y,表示坐标。 (2)无参构造方法,将坐标设置为原点。 (3)有参构造方法,将坐标设置为给定的参数。 (4)公有访问方法getX和getY,分别用于访问点的x坐标和y坐标。 再设计一个Line类,表示一条线段。Line类包括: (5)两个Point类型的实例变量。用以表示一条线段的两个端点。 (6)一个名为distance的方法,返回Point类型的两个点之间的距离。 输入样例: 0 0 3 4 输出样例(不用考虑小数位数) : 线段长度为:5.0
时间: 2024-03-23 13:42:42 浏览: 66
下面是Java代码实现:
```
public class Point {
private double x;
private double y;
public Point() {
this.x = 0;
this.y = 0;
}
public Point(double x, double y) {
this.x = x;
this.y = y;
}
public double getX() {
return this.x;
}
public double getY() {
return this.y;
}
}
public class Line {
private Point start;
private Point end;
public Line(Point start, Point end) {
this.start = start;
this.end = end;
}
public double distance() {
double dx = this.end.getX() - this.start.getX();
double dy = this.end.getY() - this.start.getY();
return Math.sqrt(dx * dx + dy * dy);
}
}
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
double x1 = scanner.nextDouble();
double y1 = scanner.nextDouble();
double x2 = scanner.nextDouble();
double y2 = scanner.nextDouble();
Point start = new Point(x1, y1);
Point end = new Point(x2, y2);
Line line = new Line(start, end);
System.out.println("线段长度为:" + line.distance());
}
}
```
阅读全文