本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是: 无论用户说什么,首先把对方说的话在一行中原样打印出来; 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉; 把原文中所有大写英文字母变成小写,除了 I; 把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词; 把原文中所有独立的 I 和 me 换成 you; 把原文中所有的问号 ? 换成惊叹号 !; 在一行中输出替换后的句子作为 AI 的回答。 输入格式: 输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。 输出格式: 按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。 输入样例: 6 Hello ? Good to chat with you can you speak Chinese? Really? Could you show me 5 What Is this prime? I,don 't know 输出样例: Hello ? AI: hello! Good to chat with you AI: good to chat with you can you speak Chinese? AI: I can speak chinese! Really? AI: really! Could you show me 5 AI: I could show you 5 What Is this prime? I,don 't know AI: what Is this prime! you,don't know c加加代码
时间: 2023-06-05 08:08:39 浏览: 166
7-1 估值一亿的AI核心代码 (25分)
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
int n;
cin >> n;
getchar(); //读入数字后要先读走换行符
while (n--)
{
string line;
getline(cin, line);
//打印用户说的话
cout << line << endl;
//消除多余空格和标点前面的空格
string new_line;
bool prev_is_punc = false; //前一个字符是否是标点符号
for (char c : line)
{
if (isalnum(c) || c == ' ') //字母或数字或空格
{
if (prev_is_punc && c == ' ')
continue; //标点符号后的空格不输出
prev_is_punc = false;
if (c == ' ') //多个空格变成一个
{
if (!new_line.empty() && new_line.back() != ' ')
new_line += c;
}
else
new_line += tolower(c);
}
else //标点符号
{
prev_is_punc = true;
if (c == '?')
new_line += '!';
else
new_line += c;
}
}
//替换独立的 can you 和 could you
int len = new_line.size();
for (int i = 0; i < len - 8; i++)
{
if (new_line[i] == ' ' && new_line.compare(i + 1, 8, "can you ") == 0)
{
new_line.replace(i + 1, 8, "I can ");
len += 4;
}
else if (new_line[i] == ' ' && new_line.compare(i + 1, 9, "could you ") == 0)
{
new_line.replace(i + 1, 9, "I could ");
len += 5;
}
}
//替换 I 和 me
for (int i = 0; i < len - 1; i++)
{
if (new_line[i] == ' ' && new_line.compare(i + 1, 2, "I ") == 0)
new_line.replace(i + 1, 2, "you ");
if (new_line[i] == ' ' && new_line.compare(i + 1, 3, "me ") == 0)
new_line.replace(i + 1, 3, "you ");
}
//输出 AI 的回答
cout << "AI: " << new_line << endl;
}
return 0;
}
阅读全文