7-1 设计一个矩形类Rectangle并创建测试程序(C++) 设计一个名为Rectangle的矩形类,这个类包括:两个名为width和height的double数据域,它们分别表示矩形的宽和高。width和height的默认值都为1.该类包括矩形类的无参构造函数(默认构造函数);一个width和height为指定值的矩形构造函数;一个名为getArea( )的函数返回矩形的面积;一个名为getPerimeter( )的函数返回矩形的周长。请实现这个类。编写一个测试程序,创建一个Rectangle对象,从键盘输入矩形的宽和高,然后输出矩形的面积和周长。 输入格式: 3.5 35.9(第一个数表示矩形的宽,第二个数表示矩形的高,中间是空间分隔。) 输出格式: 125.65 (第一行输出矩形的面积) 78.8 (第二行输出矩形的周长) 输入样例: 3.5 35.9 输出样例: 125.65 78.8
时间: 2024-03-03 20:54:02 浏览: 198
以下是C++代码实现:
```cpp
#include <iostream>
using namespace std;
class Rectangle {
private:
double width;
double height;
public:
Rectangle() {
width = 1;
height = 1;
}
Rectangle(double w, double h) {
width = w;
height = h;
}
double getArea() {
return width * height;
}
double getPerimeter() {
return 2 * (width + height);
}
};
int main() {
double w, h;
cin >> w >> h;
Rectangle rect(w, h);
cout << rect.getArea() << endl;
cout << rect.getPerimeter() << endl;
return 0;
}
```
思路:
1. 定义 Rectangle 类,包含 width 和 height 两个私有数据成员,以及无参构造函数和有参构造函数;
2. 定义 getArea() 和 getPerimeter() 成员函数,分别计算矩形的面积和周长;
3. 在 main 函数中,从键盘输入矩形的宽和高,创建一个 Rectangle 对象,并输出矩形的面积和周长。
阅读全文